Home > Uncategorized > Java + Ubuntu

Java + Ubuntu



Новата верзија на
Убунту излезе на 19ти Април. Заедно со неа, на веб се појавија еден куп статии, со помпезни претставувања, како есенцијалниот Sun Java stack (jdk, glassfish, netbeans, javadb) е спакуван за Убунту, со што е лесно достапен за корисниците на дистрибуцијата.

За инсталирање на jdk, eдно sudo apt-get install sun-java6-jkd ќе заврши работа. 6ката може да биде заменете со 5ка, која исто така се наоѓа во multiverse репозиториумите.

NetBeans-от е посебна приказна. И покрај тоа што е софтвер со отворен код, лиценциран е под CDDL лиценцата, која очигледно прави проблеми при начинот на дистрибуција (на апликацијата или на самиот код, не сум точно запознаен), така што самата инсталација оди малце поразлично од класичното инсталирање на пакети. При инсталирање на NetBeans5.5 пакетот нема да биде инсталиран netbeans-от, туку ќе бидете замолени да го преземте archive distribution bz2 пакетот од страната на NetBeans, да го ставите во /tmp директориумот, да ги промените неговите привилегии во root:root, за потоа инсталацијата да продолжи и да го инсталира netbeans-от. Овој workaround, е поправен, но покасно од code freeze-от на последната верзија на убунту. Kaко последица на последново, постои и друг начин да го инсталирате NetBeans без да ги преземате archive distributin пакетот (кој btw е 80тина мега, за разлика од класичниот linux инсталер кој е 40тина мега). Тоа можете да го направите со додавање на deb http://download.java.net/ubuntu/ feisty/ репозитоирумот и потоа покернување на sudo apt-get install netbeans5.5 (нормално претходно apt-get update). Moжно е за некоја недела пакетите од овој репозиторим да се најдат во feisty-update репозиториумот (кој е стандардно вклучен во убунту-то), така што инсталацијата нема да биде како онаа првично опишана.

Glassfish е апликациски сервер, единствен Јава ЕЕ 5. Ќе ви биде потребен ако сакате да се играте со JSF 1.2 (и други работи, нормално). Се инсталира едноставно со инсталирање на glassfish пакетот. Да не бидете изненадени што ќе ја повлече java-5 како зависност во случај да имате веќе инсталирано java-6. Тоа е нормално поради самата политика позната како lockstep (Java SE 5 – Java EE 5). Нормално, може да се промени верзијата на јава која ќе ја користи гласфишот (повеќе во литературата). При самата инсталација автоматски ќе се креира домен, сепак јас не успеав да го регистрирам тој домен во нетбинс. И покрај тоа што немам искуство во оваа работа, ми делува дека нетбинсот не е среден како што треба, се снајдов (се од нетбинсот) со креирање на нов домен во домашниот директориум и негово регистрирање. После сето ова, тест апликацијата (со помош на visual web pack-от на нетбинс) работеше без проблеми. Првичното билдување на оваа ултра едноставна аликација, подигањето на дерби и на гласфиш, траеше помалку од 45 секунди, што мислам дека е солидно.

Во случај по инсталирањето на сите овие јава компоненти, проверете која јава се користи стандардно (java|javac -version). Ако не сте задоволни со изборот можете да ја користите командата sudo update-java-alternatives за да изберете тоа што повеќе ви одговара.

Литература
Јава во Убунту – wiki.ubuntu.com/Java
Гласфиш во Убунту – http://blogs.sun.com/harpreet/entry/glassfish_on_ubuntu_with_jdk
Нетбинс во Убунту – http://blogs.sun.com/tmarble/entry/netbeans_in_ubuntu

By Andon Sikavica

Advertisements
Categories: Uncategorized
  1. November 12, 2008 at 4:30 am

    Keep up the good work.

  1. No trackbacks yet.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: